Centos 6.4 python 2.6 升级到 2.7

运维技术 jikk345 373℃ 0评论

一开始有这个需求,是因为用 YaH3C 替代 iNode 进行校园网认证时,一直编译错误,提示找不到 Python 的某个模块,百度了一下,此模块是在 Python2.7 以上才有的,但是系统的自带的Python是2.6版本,难怪一直连不上网。于是,继续百度google,进行安装,后来又出现问题…在此开篇记录一下,权当备忘。

查看python的版本
  1. python -V
  2. Python 2.6.6
1.下载Python-2.7.3
  1. wget http://python.org/ftp/python/2.7.3/Python-2.7.3.tar.bz2
  2. yum -y install readline-devel
2.解压
  1. tar -jxvf Python-2.7.3.tar.bz2 
3.更改工作目录
  1. cd Python-2.7.3
4.安装
  1. ./configure
  2. make all
  3. make install
  4. make clean
  5. make distclean
5.查看版本信息
  1. /usr/local/bin/python2.7 -V
6.建立软连接,使系统默认的 python指向 python2.7
  1. mv /usr/bin/python /usr/bin/python2.6.6
  2. ln -s /usr/local/bin/python2.7 /usr/bin/python
7.重新检验Python 版本
  1. python -V
8.解决系统 Python 软链接指向 Python2.7 版本后,因为yum是不兼容 Python 2.7的,所以yum不能正常工作,我们需要指定 yum 的Python版本
  1. vi /usr/bin/yum
  2. 将文件头部的
  3. #!/usr/bin/python
  4. 改成
  5. #!/usr/bin/python2.6.6

这篇教程就到这里了,但是不久就突然发现输入法图标不见了,然后打字没有候选框!iBus 崩了!再次进行搜索,又是版本问题iBus也是不支持Python2.7的啊!

于是。。。


9.配置iBus

分别用 vi 打开下面两个文件,找到 exec python 那一行,把exec python 改为 exec python2.6 保存,退出。iBus在重启后就恢复正常了!是不是很开心?

  1. vi /usr/bin/ibus-setup
  1. vi/usr/libexec/ibus-ui-gtk

转载请注明:清麟博客 » Centos 6.4 python 2.6 升级到 2.7

喜欢 (0)
发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址